Monday, April 4, 2011

UVa_10168_Summation_of_Four_Primes.cpp

Problem Links:

uva10168,

Problem:

Summation of Four Primes
Input: standard input
Output: standard output
Time Limit: 4 seconds

Euler proved in one of his classic theorems that prime numbers are infinite in number. But can every number be expressed as a summation of four positive primes? I don’t know the answer. May be you can help!!! I want your solution to be very efficient as I have a 386 machine at home. But the time limit specified above is for a Pentium III 800 machine. The definition of prime number for this problem is “A prime number is a positive number which has exactly two distinct integer factors”. As for example 37 is prime as it has exactly two distinct integer factors 37 and 1.

Input
The input contains one integer number N (N<=10000000) in every line. This is the number you will have to express as a summation of four primes. Input is terminated by end of file.

Output
For each line of input there is one line of output, which contains four prime numbers according to the given condition. If the number cannot be expressed as a summation of four prime numbers print the line “Impossible.” in a single line. There can be multiple solutions. Any good solution will be accepted.

Sample Input:
24
36
46

Sample Output:
3 11 3 7
3 7 13 13
11 11 17 7

Shahriar Manzoor

Solution:

First, generate the primes. then test each possibility.

Source Code:

//Mon Apr  4 13:07:11 CDT 2011
#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>
#define max_primes    10000001

using namespace std;

bool primes[max_primes];

void gen_primes()
{
    primes[0] = primes[1] = false;
    for (int i = 2; i < max_primes; ++i)
        primes[i] = true;
    for (int i = 2; i < max_primes; ++i)
    {
        if (primes[i])
            for (int j = 2; i * j < max_primes; ++j)
                primes[i * j] = false;
    }
}

void solve(int n)
{
    if (primes[n - 2])
    {
        cout << " 2 " << n - 2 << endl;
        return;
    }
    for (int i = 3; i <= n / 2; i += 2)
        if (primes[i] && primes[n - i])
        {
            cout << " " << i << " " << n - i << endl;
            return;
        }
}

int main(int argc, char* argv[])
{
    //freopen("input.in", "r", stdin);
    //freopen("output.out", "w", stdout);
    int n;
    gen_primes();
    while (cin >> n)
    {
        if (n < 8)
            cout << "Impossible." << endl;
        else if (n % 2 == 0)
        {
            cout << "2 2";
            solve(n - 4);
        }
        else
        {
            cout << "2 3";
            solve(n - 5);
        }
    }
    //fclose(stdin);
    //fclose(stdout);
    return 0;

}

No comments :