Problem Links:
uva10071,Problem:
Back to High School Physics
Input: standard input
Output: standard output
A particle has initial velocity and constant acceleration. If its velocity after certain time is v then what will its displacement be in twice of that time?
Input
The input will contain two integers in each line. Each line makes one set of input. These two integers denote the value of v (-100 <= v <= 100) and t(0<=t<= 200) ( t means at the time the particle gains that velocity)
Output
For each line of input print a single integer in one line denoting the displacement in double of that time.
Sample Input
0 05 12
Sample Output
0120
Shahriar Manzoor
Solution:
Just like high school...Source Code:
//Tue Mar 9 00:18:02 CST 2010#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>
using namespace std;
//The theory here can be proved by using geographic.
int main(int argc, const char* argv[])
{
freopen("input.txt", "r", stdin);
freopen("output.txt", "w", stdout);
int a, b;
while (cin >> a >> b)
{
cout << 2 * a * b << endl;
}
fclose(stdin);
fclose(stdout);
return 0;
}
No comments :
Post a Comment