Problem Links:
uva00543,Problem:
Goldbach's Conjecture
In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in
which he made the following conjecture:
Goldbach's Conjecture |
Every number greater than 2 can be written as the sum of three prime numbers.
Goldbach cwas considering 1 as a primer number, a convention that is no longer followed. Later on, Euler re-expressed the conjecture as:
Every even number greater than or equal to 4 can be expressed as the sum of two prime numbers.
For example:
- 8 = 3 + 5. Both 3 and 5 are odd prime numbers.
- 20 = 3 + 17 = 7 + 13.
- 42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.
Anyway, your task is now to verify Goldbach's conjecture as expressed by Euler for all even numbers less than a million.
Input
The input file will contain one or more test cases. Each test case consists of one even integer n with
Input will be terminated by a value of 0 for n.
Output
For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying ``Goldbach's conjecture is wrong."Sample Input
8 20 42 0
Sample Output
8 = 3 + 5 20 = 3 + 17 42 = 5 + 37
Miguel A. Revilla
1999-01-11
Solution:
First, generate all the prime numbers less or equal than 1000000.Then, test each prime from 3.
Source Code:
//Mon Apr 4 13:07:11 CDT 2011#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>
#define maxn 1000001
using namespace std;
bool isPrime[maxn];
void get_prime()
{
long Prime[maxn], tot;
for (long i = 1; i < maxn; i++) isPrime[i] = true;
isPrime[1] = false;
tot = 0;
for (long i = 2; i < maxn; i++)
{
if (isPrime[i])
{
tot++;
Prime[tot] = i;
}
for (long j = 1; j <= tot && i * Prime[j] < maxn; j++)
{
isPrime[i * Prime[j]] = false;
if (i % Prime[j] == 0) break;
}
}
}
void solve(int n)
{
for (int i = 3; i < maxn; i += 2)
{
if (isPrime[i] && isPrime[n - i])
{
cout << n << " = " << i << " + " << n - i << endl;
return;
}
}
cout << "Goldbach's conjecture is wrong." << endl;
return;
}
int main(int argc, char* argv[])
{
//freopen("input.in", "r", stdin);
//freopen("output.out", "w", stdout);
int n;
get_prime();
while (cin >> n && n)
{
solve(n);
}
//fclose(stdin);
//fclose(stdout);
return 0;
}
No comments :
Post a Comment