Problem Links:
poj2246, uva00442,Problem:
Matrix Chain Multiplication
Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.Matrix Chain Multiplication |
For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix. There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).
The first one takes 15000 elementary multiplications, but the second one only 3500.
Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.
Input Specification
Input consists of two parts: a list of matrices and a list of expressions.The first line of the input file contains one integer n (

The second part of the input file strictly adheres to the following syntax (given in EBNF):
SecondPart = Line { Line }Line = Expression Expression = Matrix | "(" Expression Expression ")" Matrix = "A" | "B" | "C" | ... | "X" | "Y" | "Z"
Output Specification
For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.Sample Input
9 A 50 10 B 10 20 C 20 5 D 30 35 E 35 15 F 15 5 G 5 10 H 10 20 I 20 25 A B C (AA) (AB) (AC) (A(BC)) ((AB)C) (((((DE)F)G)H)I) (D(E(F(G(HI))))) ((D(EF))((GH)I))
Sample Output
0 0 0 error 10000 error 3500 15000 40500 47500 15125
Solution:
Using stack to simulate everything.Source Code:
//Wed Apr 13 13:38:48 CDT 2011#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>
using namespace std;
class Matrix {
public:
int row;
int col;
Matrix() {
this->row = -1;
this->col = -1;
}
Matrix(int r, int c) {
this->row = r;
this->col = c;
}
};
vector<Matrix> mat;
void init(int N) {
char c;
int a, b;
mat.clear();
mat.resize(26);
for (int i = 0; i < N; i++) {
cin >> c >> a >> b;
mat[c - 'A'] = Matrix(a, b);
}
// for (int i = 0; i < 26; i++)
// cout << char('A' + i) << mat[i].row << ", " << mat[i].col << endl;
}
int process(string s) {
stack<Matrix> expression;
// cout << s << endl;
int sum = 0;
for (int i = 0; i < s.size(); i++) {
if (s[i] == '(')
continue;
else if (s[i] == ')') {
Matrix a = expression.top();
expression.pop();
Matrix b = expression.top();
expression.pop();
if (a.row != b.col)
return -1;
sum += b.row * b.col * a.col;
expression.push(Matrix(b.row, a.col));
} else
expression.push(mat[s[i] - 'A']);
}
return sum;
}
void solve() {
string s;
while (cin >> s) {
int ret = process(s);
if (ret != -1)
cout << ret << endl;
else
cout << "error" << endl;
}
}
int main(int argc, const char* argv[]) {
//freopen("input.in", "r", stdin);
//freopen("output.out", "w", stdout);
int N;
cin >> N;
init(N);
solve();
//fclose(stdin);
//fclose(stdout);
return 0;
}
No comments :
Post a Comment