Problem Links:
uva00409, poj1598,Problem:
Excuses, Excuses!
Judge Ito is having a problem with people subpoenaed for jury duty giving rather lame excuses in order to avoid serving. In order to reduce the amount of time required listening to goofy excuses, Judge Ito has asked that you write a program that will search for a list of keywords in a list of excuses identifying lame excuses. Keywords can be matched in an excuse regardless of case.Excuses, Excuses! |
Input
Input to your program will consist of multiple sets of data.- Line 1 of each set will contain exactly two integers. The first number (
) defines the number of keywords to be used in the search. The second number (
) defines the number of excuses in the set to be searched.
- Lines 2 through K+1 each contain exactly one keyword.
- Lines K+2 through K+1+E each contain exactly one excuse.
- All keywords in the keyword list will contain only contiguous lower case alphabetic characters of length L (
) and will occupy columns 1 through L in the input line.
- All excuses can contain any upper or lower case alphanumeric character, a space, or any of the following punctuation marks [
SPMamp
".,!?&] not including the square brackets and will not exceed 70 characters in length. - Excuses will contain at least 1 non-space character.
Output
For each input set, you are to print the worst excuse(s) from the list.- The worst excuse(s) is/are defined as the excuse(s) which contains the largest number of incidences of keywords.
- If a keyword occurs more than once in an excuse, each occurrance is considered a separate incidence.
- A keyword ``occurs" in an excuse if and only if it exists in the string in contiguous form and is delimited by the beginning or end of the line or any non-alphabetic character or a space.
After each set of output, you should print a blank line.
Sample Input
5 3 dog ate homework canary died My dog ate my homework. Can you believe my dog died after eating my canary... AND MY HOMEWORK? This excuse is so good that it contain 0 keywords. 6 5 superhighway crazy thermonuclear bedroom war building I am having a superhighway built in my bedroom. I am actually crazy. 1234567890.....,,,,,0987654321?????!!!!!! There was a thermonuclear war! I ate my dog, my canary, and my homework ... note outdated keywords?
Sample Output
Excuse Set #1 Can you believe my dog died after eating my canary... AND MY HOMEWORK? Excuse Set #2 I am having a superhighway built in my bedroom. There was a thermonuclear war!
Solution:
ad-hoc;Create the dictionary, then check each word in the line, to see if it's in the dictionary.
Source Code:
//Fri Apr 22 18:19:01 CDT 2011#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>
using namespace std;
class Word {
public:
string s;
int sum;
Word() {
s = "";
sum = 0;
}
static bool cmp(const Word &A, const Word &B) {
return A.sum > B.sum;
}
};
set<string> excuse;
vector<Word> occurs;
void init(int k, int e) {
excuse.clear();
occurs.clear();
occurs.resize(e, Word());
string s;
for (int i = 0; i < k; i++) {
cin >> s;
excuse.insert(s);
}
}
void processLine(int row) {
string line = occurs[row].s;
int sum = 0;
string s = "";
set<string>::iterator it;
for (int i = 0; i < (int) line.size(); i++) {
if (isalpha(line[i])) {
s += tolower(line[i]);
} else {
if (s.empty() == false) {
it = excuse.find(s);
if (it != excuse.end())
sum++;
}
s.clear();
}
}
occurs[row].sum = sum;
}
void solve(int e) {
getchar();
for (int i = 0; i < e; i++) {
getline(cin, occurs[i].s, '\n');
processLine(i);
}
sort(occurs.begin(), occurs.end(), Word::cmp);
int sum = occurs[0].sum;
for (int i = 0; i < e; i++)
if (occurs[i].sum == sum)
cout << occurs[i].s << endl;
else
break;
}
int main(int argc, char* argv[]) {
// freopen("input.in", "r", stdin);
//freopen("output.out", "w", stdout);
int K, E;
int counter = 1;
while (cin >> K >> E) {
cout << "Excuse Set #" << counter++ << endl;
init(K, E);
solve(E);
cout << endl;
}
// fclose(stdin);
//fclose(stdout);
return 0;
}
No comments :
Post a Comment