Saturday, April 16, 2011

poj_3094_Quicksum.cpp

Problem Links:

poj3094,

Problem:


Quicksum
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 8505Accepted: 5935
Description
A checksum is an algorithm that scans a packet of data and returns a single number. The idea is that if the packet is changed, the checksum will also change, so checksums are often used for detecting transmission errors, validating document contents, and in many other situations where it is necessary to detect undesirable changes in data.
For this problem, you will implement a checksum algorithm called Quicksum. A Quicksum packet allows only uppercase letters and spaces. It always begins and ends with an uppercase letter. Otherwise, spaces and letters can occur in any combination, including consecutive spaces.
A Quicksum is the sum of the products of each character's position in the packet times the character's value. A space has a value of zero, while letters have a value equal to their position in the alphabet. So, A=1, B=2, etc., through Z=26. Here are example Quicksum calculations for the packets "ACM" and "MID CENTRAL":
        ACM: 1*1  + 2*3 + 3*13 = 46

MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 + 9*18 + 10*1 + 11*12 = 650
Input
The input consists of one or more packets followed by a line containing only # that signals the end of the input. Each packet is on a line by itself, does not begin or end with a space, and contains from 1 to 255 characters.
Output
For each packet, output its Quicksum on a separate line in the output.
Sample Input
ACM
MID CENTRAL
REGIONAL PROGRAMMING CONTEST
ACN
A C M
ABC
BBC
#
Sample Output
46
650
4690
49
75
14
15
Source
Mid-Central USA 2006


Solution:

ad-hoc;

Source Code:

//Sat Apr 16 14:25:29 CDT 2011
#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>

using namespace std;

int translate(char c) {
    if (c == ' ')
        return 0;
    return c - 'A' + 1;
}

int process(string s) {
    int sum = 0;
    for (int i = 0; i < s.size(); i++)
        sum += (i + 1) * translate(s[i]);
    return sum;
}

int main(int argc, const char* argv[]) {
//  freopen("input.in", "r", stdin);
    //freopen("output.out", "w", stdout);
    string s;
    while (getline(cin, s) && s != "#") {
        cout << process(s) << endl;
    }
//  fclose(stdin);
    //fclose(stdout);
    return 0;
}

No comments :