Problem Links:
uva10050,Problem:
Problem D: Hartals
A social research organization has determined a simple set of parameters to simulate
the behavior of the political parties of our country. One of the parameters is a positive integer
h (called the hartal parameter) that denotes the average number of days
between two successive hartals (strikes) called by the corresponding
party. Though the parameter is far too simple to be flawless, it can still be
used to forecast the damages caused by hartals. The following example
will give you a clear idea:
Problem D: Hartals |
Consider three political parties. Assume h1 = 3, h2 = 4 and h3 = 8 where hi is the hartal parameter for party i ( i = 1, 2, 3). Now, we will simulate the behavior of these three parties for N = 14 days. One must always start the simulation on a Sunday and assume that there will be no hartals on weekly holidays (on Fridays and Saturdays).
1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | |
Days | ||||||||||||||
Su | Mo | Tu | We | Th | Fr | Sa | Su | Mo | Tu | We | Th | Fr | Sa | |
Party 1 | x | x | x | x | ||||||||||
Party 2 | x | x | x | |||||||||||
Party 3 | x | |||||||||||||
Hartals | 1 | 2 | 3 | 4 | 5 |
The simulation above shows that there will be exactly 5 hartals (on days 3, 4, 8, 9 and 12) in 14 days. There will be no hartal on day 6 since it is a Friday. Hence we lose 5 working days in 2 weeks.
In this problem, given the hartal parameters for several political parties and the value of N, your job is to determine the number of working days we lose in those N days.
Input
The first line of the input consists of a single integer T giving the number of test cases to follow.The first line of each test case contains an integer N (



Output
For each test case in the input output the number of working days we lose. Each output must be on a separate line.Sample Input
2 14 3 3 4 8 100 4 12 15 25 40
Sample Output
5 15
Miguel Revilla
2000-12-26
Solution:
Simulation, use array mapping.Source Code:
//Mon Mar 14 14:17:16 CDT 2011#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>
using namespace std;
int main(int argc, char* argv[])
{
//freopen("input.in", "r", stdin);
//freopen("output.out", "w", stdout);
int T;
cin >> T;
while (T--)
{
int N, P;
cin >> N >> P;
vector<bool> flag(N, false);
int days;
for (int k = 0; k < P; k++)
{
cin >> days;
for (int i = days-1; i < N; i += days)
flag[i] = true;
}
int count = 0;
for (int i = 0; i < N; i++)
{
if (i % 7 != 5 && i % 7 != 6 && flag[i])
count++;
}
cout << count << endl;
}
//fclose(stdin);
//fclose(stdout);
return 0;
}
No comments :
Post a Comment