Problem Links:
uva10041,Problem:
Problem C: Vito's family
Problem C: Vito's family |
Background
The world-known gangster Vito Deadstone is moving to New York. He has a very big family there, all of them living in Lamafia Avenue. Since he will visit all his relatives very often, he is trying to find a house close to them.Problem
Vito wants to minimize the total distance to all of them and has blackmailed you to write a program that solves his problem.Input
The input consists of several test cases. The first line contains the number of test cases. For each test case you will be given the integer number of relatives r ( 0 < r < 500) and the street numbers (also integers)
Output
For each test case your program must write the minimal sum of distances from the optimal Vito's house to each one of his relatives. The distance between two street numbers si and sj is dij= |si-sj|.Sample Input
2 2 2 4 3 2 4 6
Sample Output
2 4
Miguel Revilla
2000-11-19
Solution:
Sort.Source Code:
//Fri Mar 18 00:46:05 CDT 2011#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>
using namespace std;
void initialize(int n, vector<int> &v)
{
for (int i = 0; i < n; i++)
cin >> v[i];
}
int solve(int n, vector<int> &v)
{
sort(v.begin(), v.end());
int mid = n / 2;
int sum = 0;
for (int i = 0; i < n; i++)
sum += abs(v[i] - v[mid]);
return sum;
}
int main(int argc, char* argv[])
{
//freopen("input.in", "r", stdin);
//freopen("output.out", "w", stdout);
int T;
cin >> T;
while (T--)
{
int n;
cin >> n;
vector<int> v(n, 0);
initialize(n, v);
cout << solve(n, v) << endl;
}
//fclose(stdin);
//fclose(stdout);
return 0;
}
No comments :
Post a Comment