Problem Links:
poj2629, uva10252,Problem:
Problem G
Common Permutation
Input: standard input
Output: standard output
Time Limit: 4 seconds
Memory Limit: 32 MB
Given
two strings of lowercase letters, a
and b, print the longest
string x of lowercase letters
such that there is a permutation of x
that is a subsequence of a
and there is a permutation of x
that is a subsequence of b.
Input
Input file contains several lines of input.
Consecutive two lines make a set of input. That means in the input file line 1 and 2 is a set of input, line 3
and 4 is a set of input and so on.
The first line of a pair contains a
and the second contains b.
Each string is on a separate line and consists of at most 1000 lowercase letters.
Output
For each set of input, output a line containing x. If several x satisfy the criteria above,
choose the first one in alphabetical order.
Sample Input:
pretty
women
walking
down
the
street
Sample Output:
e
nw
et
Solution:
Just take care of input data, there is a blank line between each string.Source Code:
//Wed Mar 16 22:14:38 CDT 2011#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>
using namespace std;
string solve(string s1, string s2)
{
string str = "";
for (int i = 0; i < s1.size(); i++)
{
if (isalpha(s1[i]) == false) continue;
int found = s2.find(s1[i]);
if (found != string::npos)
{
str += s1[i];
s2[found] = '.';
}
}
std::sort(str.begin(), str.end());
return str;
}
int main(int argc, char* argv[])
{
//freopen("input.in", "r", stdin);
//freopen("output.out", "w", stdout);
char s1[1001], s2[1001];
while (gets(s1))
{
//getchar();
gets(s2);
//getchar();
cout << solve(string(s1), string(s2)) << endl;
}
//fclose(stdin);
//fclose(stdout);
return 0;
}
No comments :
Post a Comment