Saturday, October 30, 2010

poj_3176_Cow_Bowling.cpp

Problem Links:


poj3176,

Problem:


Cow Bowling















Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 7685Accepted: 5014


Description
The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this:
          7



3 8



8 1 0



2 7 4 4



4 5 2 6 5

Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame.

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input
Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output
Line 1: The largest sum achievable using the traversal rules

Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output
30

Hint
Explanation of the sample:
          7

*

3 8

*

8 1 0

*

2 7 4 4

*

4 5 2 6 5

The highest score is achievable by traversing the cows as shown above.

Source
USACO 2005 December Bronze

Solution:


Basic Dynamic Programming problem.

Source Code:


[sourcecode language="cpp" collapse="true" padlinenumbers="true"]
//Sat 30 Jan 2010 09:57:32 PM CST
#include <iostream>
#include <string>
#include <vector>

using namespace std;

int main()
{
int N;
cin >> N;
vector<vector<int> > v;
for(int i=0; i<N; i++)
{
vector<int> temp (i+1);
for(int j=0; j<=i; j++)
{
cin >> temp[j];
}
v.push_back(temp);
}
for(int i=1; i<N; i++)
{
for(int j=0; j<=i; j++)
{
if(j==0) v[i][j] += v[i-1][j];
else if(j==i) v[i][j] += v[i-1][j-1];
else v[i][j] += max(v[i-1][j-1], v[i-1][j]);
}
}
int mmax = 0;
for(int i=0; i<N; i++)
mmax = max(mmax, v[N-1][i]);
cout << mmax << endl;
return 0;
}
[/sourcecode]

No comments :