Saturday, October 30, 2010

poj_3100_Root_of_the_Problem.cpp

Problem Links:


poj3100,

Problem:


Root of the Problem















Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 8575Accepted: 4589


Description


Given positive integers B and N, find an integer A such that AN is as close as possible to B. (The result A is an approximation to the Nth root of B.) Note that AN may be less than, equal to, or greater than B.


Input


The input consists of one or more pairs of values for B and N. Each pair appears on a single line, delimited by a single space. A line specifying the value zero for both B and N marks the end of the input. The value of B will be in the range 1 to 1,000,000 (inclusive), and the value of N will be in the range 1 to 9 (inclusive).


Output


For each pair B and N in the input, output A as defined above on a line by itself.


Sample Input
4 3
5 3
27 3
750 5
1000 5
2000 5
3000 5
1000000 5
0 0

Sample Output
1
2
3
4
4
4
5
16

Source
Mid-Central USA 2006

Solution:


Easy implementation. But take care.

Source Code:


[sourcecode language="cpp" collapse="true" padlinenumbers="true"]
//Sun 31 Jan 2010 04:43:48 PM CST
#include <iostream>
#include <string>
#include <vector>
#include <cmath>

using namespace std;

int main()
{
int B, N;
cin >> B >> N;
while(B + N != 0)
{
int ret = (int) pow(B, 1.0/N);
int res1 = (int) pow(ret, 1.0*N);
int res2 = (int) pow(ret+1, 1.0*N);
if(res1+res2 > 2*B) cout << ret << endl;
else cout << ret+1 << endl;
cin >> B >> N;
}
return 0;
}
[/sourcecode]

No comments :