Saturday, October 30, 2010

poj_2909_Goldbach_s_Conjecture.cpp

Problem Links:


poj2909,

Problem:

Goldbach's Conjecture
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 7566
Accepted: 4382
Description
For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that
n = p1 + p2
This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.
A sequence of even numbers is given as input. There can be many such numbers. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.
Input
An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 215. The end of the input is indicated by a number 0.
Output
Each output line should contain an integer number. No other characters should appear in the output.
Sample Input
6
10
12
0
Sample Output
1
2
1
Source
Svenskt Mästerskap i Programmering/Norgesmesterskapet 2002

Solution:


Just like POJ 2262.

Source Code:

//Fri May 21 17:33:08 CDT 2010
#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>

#define m 1000000
bool v[m];

using namespace std;

void Prime()
{
    v[0] = v[1] = true;
    for (int i = 2; i < m; i++)
        if (v[i] == false)
            for (int j = i + i; j < m; j += i)
                v[j] = true;
    return;
}

int main(int argc, const char* argv[])
{
//  freopen("input.in", "r", stdin);
//  freopen("output.out", "w", stdout);
    Prime();
    int N;
    while (cin >> N && N)
    {
        long count = 0;
        if (N % 2 != 0 && v[N - 2] == false)
        {
            count++;
        }
        for (int i = 3; i <= N / 2; i += 2)
        {
            if (v[i] == false && v[N - i] == false)
            {
                count++;
            }
        }
        cout << count << endl;
    }
//  fclose(stdin);
//  fclose(stdout);
    return 0;
}

No comments :