Problem Links:
poj2752,
Problem:
Seek the Name, Seek the Fame
Description
The
little cat is so famous, that many couples tramp over hill and dale to
Byteland, and asked the little cat to give names to their newly-born
babies. They seek the name, and at the same time seek the fame. In order
to escape from such boring job, the innovative little cat works out an
easy but fantastic algorithm:
Step1. Connect the father's name and the mother's name, to a new string S. Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)
Input
The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.
Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.
Output
For
each test case, output a single line with integer numbers in increasing
order, denoting the possible length of the new baby's name.
Sample Input
ababcababababcabab aaaaa
Sample Output
2 4 9 18 1 2 3 4 5
Source
POJ Monthly--2006.01.22,Zeyuan Zhu
|
Solution:
It's from others: code.
Source Code:
//Wed May 26 16:05:21 CDT 2010#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>
using namespace std;
void kmp(string &str, vector<int> &data)
{
int i = 0;
int j = -1;
data[0] = -1;
while (i < (int) str.size())
{
if (j == -1 || str[i] == str[j])
{
i++;
j++;
data[i] = j;
}
else
{
j = data[j];
}
}
return;
}
int main(int argc, const char* argv[])
{
// freopen("input.in", "r", stdin);
// freopen("output.out", "w", stdout);
string str;
while (cin >> str)
{
int N = str.size();
vector<int> next(N + 1, 0);
kmp(str, next);
// for (int i = 0; i <= N; i++)
// {
// cout << " " << next[i];
// }
// cout << endl;
int j = N;
vector<int> position;
while (j != 0)
{
position.push_back(j);
j = next[j];
}
int temp = position[position.size() - 1];
cout << temp;
position.pop_back();
while (position.empty() == false)
{
temp = position[position.size() - 1];
cout << " " << temp;
position.pop_back();
}
cout << endl;
}
// fclose(stdin);
// fclose(stdout);
return 0;
}
No comments :
Post a Comment