Problem Links:
poj2602,
Problem:
Superlong sums
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 18724 | Accepted: 5381 |
Description
The
creators of a new programming language D++ have found out that whatever
limit for SuperLongInt type they make, sometimes programmers need to
operate even larger numbers. A limit of 1000 digits is so small... You
have to find the sum of two numbers with maximal size of 1.000.000
digits.
Input
The
first line of an input file contains a single number N
(1<=N<=1000000) - the length of the integers (in order to make
their lengths equal, some leading zeroes can be added). It is followed
by these integers written in columns. That is, the next N lines contain
two digits each, divided by a space. Each of the two given integers is
not less than 1, and the length of their sum does not exceed N.
Output
Output file should contain exactly N digits in a single line representing the sum of these two integers.
Sample Input
4 0 4 4 2 6 8 3 7
Sample Output
4750
Hint
Huge input,scanf is recommended.
Source
Ural State University collegiate programming contest 2000
Solution:
Source Code:
#include<stdio.h>int sum[1000000];
int main()
{
int n;
scanf("%d",&n);
int i;
int aa,bb;
for(i=0;i<n;i++)
{
scanf("%d%d",&aa,&bb);
sum[i] = aa + bb;
}
int flag=0;
for(i=n-1;i>=0;i--)
{
sum[i] += flag;
if(sum[i] > 9) flag = 1;
else flag = 0 ;
sum[i]%=10;
}
for(i=0;i<n;i++)
{
printf("%d",sum[i]);
}
printf("\n");
return 0;
}
No comments :
Post a Comment