Saturday, October 30, 2010

poj_2524_Ubiquitous_Religions.cpp

Problem Links:


poj2524, UVa10583.

Problem:

Ubiquitous Religions
Time Limit: 5000MS
Memory Limit: 65536K
Total Submissions: 13645
Accepted: 6499
Description
There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.
Input
The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.
Output
For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.
Sample Input
10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0
Sample Output
Case 1: 1
Case 2: 7
Hint
Huge input, scanf is recommended.
Source
Alberta Collegiate Programming Contest 2003.10.18

Solution:


Basic Disjoint-set data structure, using Union-find algorithms.

Source Code:

//Thu Jun  3 12:06:11 EDT 2010
#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>
#define MMAX 50005
using namespace std;

class Religions
{
public:
    int parent;
    int rank;
};

vector<Religions> v(MMAX);

void MakeSet(vector<Religions> &v, int N)
{
    for (int i = 1; i <= N; i++)
    {
        v[i].parent = i;
        v[i].rank = 1;
    }
}

int Find(vector<Religions> &v, int x)
{
    int p = x;
    while (p != v[p].parent)
        p = v[p].parent;
    while (x != p)
    {
        int temp = v[x].parent;
        v[x].parent = p;
        x = temp;
    }
    return p;
}

void Union(vector<Religions> &v, int x, int y, int &count)
{
    int t1 = Find(v, x);
    int t2 = Find(v, y);
    if (t1 == t2)
        return;
    count--;
    if (v[t1].rank > v[t2].rank)
    {
        v[t2].parent = t1;
        v[t1].rank += v[t2].rank;
    }
    else
    {
        v[t1].parent = t2;
        v[t2].rank += v[t1].rank;
    }
    return;
}

int main(int argc, const char* argv[])
{
//  freopen("input.in", "r", stdin);
//  freopen("output.out", "w", stdout);
    int N, M;
    int ncase = 0;
    while (scanf("%d %d", &N, &M) && (N + M))
    {
        int count = N;
        MakeSet(v, N);
        for (int i = 0; i < M; i++)
        {
            int x, y;
            scanf("%d %d", &x, &y);
            Union(v, x, y, count);
        }
        cout << "Case " << ++ncase << ": " << count << endl;
    }
//  fclose(stdin);
//  fclose(stdout);
    return 0;
}

No comments :