Thursday, October 28, 2010

poj_2388_Who_s_in_the_Middle.cpp

Problem Links:


poj2388,

Problem:


Who's in the Middle
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 17758
Accepted: 10087
Description
FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less.



Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
Input
* Line 1: A single integer N

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
Output
* Line 1: A single integer that is the median milk output.
Sample Input
5
2
4
1
3
5
Sample Output
3
Hint
INPUT DETAILS:

Five cows with milk outputs of 1..5

OUTPUT DETAILS:

1 and 2 are below 3; 4 and 5 are above 3.
Source
USACO 2004 November

Solution:


... , Hope to see some other ways to implement this.

Source Code:

//Mon Apr 19 01:47:31 CDT 2010
#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>

using namespace std;

int main( int argc, const char* argv[] )
{
//  freopen("input.in", "r", stdin);
//  freopen("output.out", "w", stdout);
    int N;
    while(cin >> N)
    {
        vector<int> v(N);
        for(int i=0; i<N; i++)
            cin >> v[i];
        sort(v.begin(), v.end());
        cout << v[N/2];
    }
//  fclose(stdin);
//  fclose(stdout);
    return 0;
}

No comments :