Thursday, October 28, 2010

poj_2350_Above_Average.cpp

Problem Links:


poj2350, uva10370,

Problem:

Above Average
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 11280
Accepted: 5952
Description
It is said that 90% of frosh expect to be above average in their class. You are to provide a reality check.
Input
The first line of standard input contains an integer C, the number of test cases. C data sets follow. Each data set begins with an integer, N, the number of people in the class (1 <= N <= 1000). N integers follow, separated by spaces or newlines, each giving the final grade (an integer between 0 and 100) of a student in the class.
Output
For each case you are to output a line giving the percentage of students whose grade is above average, rounded to 3 decimal places.
Sample Input
5
5 50 50 70 80 100
7 100 95 90 80 70 60 50
3 70 90 80
3 70 90 81
9 100 99 98 97 96 95 94 93 91
Sample Output
40.000%
57.143%
33.333%
66.667%
55.556%
Source
Waterloo local 2002.09.28

Solution:


Source Code:

//Thu 04 Feb 2010 02:17:42 AM CST
#include <iostream>
#include <string>
#include <vector>
#include <cstdio>

using namespace std;

int main(int argc, char* argv[])
{
    int C;
    cin >> C;
    for(int c=0; c<C; c++)
    {
        int N;
        cin >> N;
        vector<int> v(N, 0);
        int sum = 0;
        for(int i=0; i<N; i++)
        {
            cin >> v[i];
            sum += v[i];
        }
        int count = 0;
        for(int i=0; i<N; i++)
        {
            if(v[i]*N > sum)
                count ++;
        }
        printf("%.3f%%\n", 100.0*count / N);
    }
    return 0;
}

No comments :