Thursday, October 28, 2010

poj_2262_Goldbach_s_Conjecture.cpp

Problem Links:


poj2262,

Problem:

Goldbach's Conjecture
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 22150
Accepted: 8828
Description
In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture:
Every even number greater than 4 can be
written as the sum of two odd prime numbers.

For example:
8 = 3 + 5. Both 3 and 5 are odd prime numbers.
20 = 3 + 17 = 7 + 13.
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.)
Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million.
Input
The input will contain one or more test cases.
Each test case consists of one even integer n with 6 <= n < 1000000.
Input will be terminated by a value of 0 for n.
Output
For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."
Sample Input
8
20
42
0
Sample Output
8 = 3 + 5
20 = 3 + 17
42 = 5 + 37
Source
Ulm Local 1998

Solution:


Take a great look at the Prime Table.
Don't use map, it will slower your code.

Source Code:

//Fri May 21 16:55:41 CDT 2010
#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>
#define m 1000000
bool v[m];

using namespace std;

void Prime()
{
    v[0] = v[1] = true;
    for (int i = 2; i < m; i++)
        if (v[i] == false)
            for (int j = i + i; j < m; j += i)
                v[j] = true;
    return;
}

int main(int argc, const char* argv[])
{
//  freopen("input.in", "r", stdin);
//  freopen("output.out", "w", stdout);
    Prime();
    int N;
    while (cin >> N && N)
    {
        if (N % 2 != 0 && v[N - 2] == false)
        {
            cout << N << " = " << "2" << " + " << N - 2 << endl;
        }
        for (int i = 3; i <= N / 2; i += 2)
        {
            if (v[i] == false && v[N - i] == false)
            {
                cout << N << " = " << i << " + " << N - i << endl;
                break;
            }
        }
    }
//  fclose(stdin);
//  fclose(stdout);
    return 0;
}

No comments :