Thursday, October 28, 2010

poj_2109_Power_of_Cryptography.cpp

Problem Links:


poj2109,

Problem:

Power of Cryptography
Time Limit: 1000MS
Memory Limit: 30000K
Total Submissions: 9819
Accepted: 5050
Description
Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be only of theoretical interest.
This problem involves the efficient computation of integer roots of numbers.
Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the nth. power, for an integer k (this integer is what your program must find).
Input
The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10101 and there exists an integer k, 1<=k<=109 such that kn = p.
Output
For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.
Sample Input
2 16
3 27
7 4357186184021382204544
Sample Output
4
3
1234
Source
México and Central America 2004

Solution:


Straight Forward Problem.

Source Code:

//Wed Apr 14 12:17:16 CDT 2010
#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>

using namespace std;

int main( int argc, const char* argv[] )
{
    freopen("input.in", "r", stdin);
    freopen("output.out", "w", stdout);
    double n, p;
    while(cin >> n >> p)
    {
        cout << (int) round(pow(p, 1/n)) << endl;
    }
    fclose(stdin);
    fclose(stdout);
    return 0;
}

No comments :