Thursday, October 28, 2010

poj_2027_NoBrainer.cpp

Problem Links:


poj2027,

Problem:

No Brainer
Time Limit: 1000MS
Memory Limit: 30000K
Total Submissions: 16036
Accepted: 10821
Description
Zombies love to eat brains. Yum.
Input
The first line contains a single integer n indicating the number of data sets.

The following n lines each represent a data set. Each data set will be formatted according to the following description:

A single data set consists of a line "X Y", where X is the number of brains the zombie eats and Y is the number of brains the zombie requires to stay alive.
Output
For each data set, there will be exactly one line of output. This line will be "MMM BRAINS" if the number of brains the zombie eats is greater than or equal to the number of brains the zombie requires to stay alive. Otherwise, the line will be "NO BRAINS".
Sample Input
3
4 5
3 3
4 3
Sample Output
NO BRAINS
MMM BRAINS
MMM BRAINS
Source
South Central USA 2004

Solution:


Source Code:

#include<stdio.h>
int main()
{
    int n;
    while(scanf("%d",&n)==1)
    {
        while(n--)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            if(a>=b)
                printf("MMM BRAINS\n");
            else
                printf("NO BRAINS\n");
        }
    }
    return 0;
}

No comments :