Problem Links:
poj1961, spoj00263,
Problem:
Period
Time Limit: 3000MS | Memory Limit: 30000K | |
Total Submissions: 6886 | Accepted: 2977 |
Description
For
each prefix of a given string S with N characters (each character has
an ASCII code between 97 and 126, inclusive), we want to know whether
the prefix is a periodic string. That is, for each i (2 <= i <= N)
we want to know the largest K > 1 (if there is one) such that the
prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The
input consists of several test cases. Each test case consists of two
lines. The first one contains N (2 <= N <= 1 000 000) – the size
of the string S.The second line contains the string S. The input file
ends with a line, having the
number zero on it.
number zero on it.
Output
For
each test case, output "Test case #" and the consecutive test case
number on a single line; then, for each prefix with length i that has a
period K > 1, output the prefix size i and the period K separated by a
single space; the prefix sizes must be in increasing order. Print a
blank line after each test case.
Sample Input
3 aaa 12 aabaabaabaab 0
Sample Output
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
Source
Southeastern Europe 2004
Solution:
Take care of the KMP table building.
Source Code:
//Tue May 4 00:05:17 CDT 2010#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>
using namespace std;
void kmp(string &str, vector<int> &data)
{
int i = 0;
int j = -1;
data[0] = -1;
while (i < (int) str.size())
{
if (j == -1 || str[i] == str[j])
{
i++;
j++;
data[i] = j;
}
else
{
j = data[j];
}
}
return;
}
int main(int argc, const char* argv[])
{
freopen("input.in", "r", stdin);
freopen("output.out", "w", stdout);
int ncase = 1;
int N;
while (cin >> N && N != 0)
{
// length = N;
string str;
cin >> str;
vector<int> next(N + 1, 0);
cout << "Test case #" << ncase << endl;
kmp(str, next);
for (int i = 0; i < N; i++)
{
cout << " " << next[i];
}
cout << endl;
for (int k = 1; k <= N; k++)
{
if (k % (k - next[k]) == 0 && k / (k - next[k]) > 1)
{
cout << k << " " << (k) / (k - next[k]) << endl;
}
}
ncase++;
cout << endl;
}
fclose(stdin);
fclose(stdout);
return 0;
}
No comments :
Post a Comment