Saturday, August 28, 2010

poj_1611_The_Suspects.cpp

Problem Links:

Poj1611, Zoj1789,

Problem:

The Suspects
Time Limit: 1000MS
Memory Limit: 20000K
Total Submissions: 10142
Accepted: 4839
Description
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1
Source
Asia Kaohsiung 2003

Solution:


Disjoint set data structure, using find-union algorithms.

Source Code:

//Fri Jun  4 01:13:00 EDT 2010
#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>
#define MMAX 30001
using namespace std;

class Suspects
{
public:
    int parent; //The number of element in the union at root, else it's the parent's number;
};

vector<Suspects> v(MMAX);

void MakeSet(int N)
{
    for (int i = 0; i < N; i++)
    {
        v[i].parent = -1;
    }
}

int Find(int x)
{
    int p = x;
    while (v[p].parent > 0)
        p = v[p].parent;
    while (x != p)
    {
        int temp = v[x].parent;
        v[x].parent = p;
        x = temp;
    }
    return p;
}

void Union(int x, int y)
{
    int t1 = Find(x);
    int t2 = Find(y);
    if (t1 == t2)
        return;
    if (v[t1].parent >= v[t2].parent)
    {
        v[t2].parent += v[t1].parent;
        v[t1].parent = t2;
    }
    else
    {
        v[t1].parent += v[t2].parent;
        v[t2].parent = t1;
    }
}

int main(int argc, const char* argv[])
{
    //  freopen("input.in", "r", stdin);
    //  freopen("output.out", "w", stdout);
    int M, N;
    while ((cin >> N >> M) && (M + N))
    {
        MakeSet(N);
        for (int i = 0; i < M; i++)
        {
            int k, num;
            cin >> k >> num;
            Union(num, num);
            for (int j = 1; j < k; j++)
            {
                int temp;
                cin >> temp;
                Union(num, temp);
            }
        }
        cout << -v[Find(0)].parent << endl;
    }
    //  fclose(stdin);
    //  fclose(stdout);
    return 0;
}

No comments :