Problem Links:
poj1458,Problem:
Common Subsequence
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 22340 | Accepted: 8524 |
Description
A
subsequence of a given sequence is the given sequence with some
elements (possible none) left out. Given a sequence X = < x1, x2,
..., xm > another sequence Z = < z1, z2, ..., zk > is a
subsequence of X if there exists a strictly increasing sequence < i1,
i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij
= zj. For example, Z = < a, b, f, c > is a subsequence of X =
< a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >.
Given two sequences X and Y the problem is to find the length of the
maximum-length common subsequence of X and Y.
Input
The
program input is from the std input. Each data set in the input
contains two strings representing the given sequences. The sequences are
separated by any number of white spaces. The input data are correct.
Output
For
each set of data the program prints on the standard output the length
of the maximum-length common subsequence from the beginning of a
separate line.
Sample Input
abcfbc abfcab programming contest abcd mnp
Sample Output
4 2 0
Source
Southeastern Europe 2003
Solution:
Basically, it's a straight forward dynamic programming problem----longest common subsequence.
It's pretty much like POJ1159, I used the same subfunction to get the answer.
Source Code:
//Tue Apr 13 15:46:54 CDT 2010#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>
using namespace std;
int LongestIncreasingCommonSubsequence(string A, string B)
{
int N = A.size();
int M = B.size();
vector<vector<int> > v(N + 1, vector<int>(M + 1, 0));
for (int i = 0; i <= N; i++)
{
for (int j = 0; j <= M; j++)
{
if (i == 0 || j == 0)
v[i][j] = 0;
else if(A[i-1] == B[j-1])
v[i][j] = v[i-1][j-1] + 1;
else
v[i][j] = max(v[i-1][j], v[i][j-1]);
}
}
return v[N][M];
}
int main(int argc, const char* argv[])
{
freopen("input.in", "r", stdin);
freopen("output.out", "w", stdout);
string str1, str2;
while(cin >> str1 >> str2)
{
cout << LongestIncreasingCommonSubsequence(str1, str2) << endl;
}
fclose(stdin);
fclose(stdout);
return 0;
}
No comments :
Post a Comment