Saturday, August 28, 2010

poj_1218_THE_DRUNK_JAILER.cpp

Problem Links:

poj1218,

Problem:

THE DRUNK JAILER
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 15411
Accepted: 9890
Description
A certain prison contains a long hall of n cells, each right next to each other. Each cell has a prisoner in it, and each cell is locked.
One night, the jailer gets bored and decides to play a game. For round 1 of the game, he takes a drink of whiskey,and then runs down the hall unlocking each cell. For round 2, he takes a drink of whiskey, and then runs down the
hall locking every other cell (cells 2, 4, 6, ?). For round 3, he takes a drink of whiskey, and then runs down the hall. He visits every third cell (cells 3, 6, 9, ?). If the cell is locked, he unlocks it; if it is unlocked, he locks it. He
repeats this for n rounds, takes a final drink, and passes out.
Some number of prisoners, possibly zero, realizes that their cells are unlocked and the jailer is incapacitated. They immediately escape.
Given the number of cells, determine how many prisoners escape jail.
Input
The first line of input contains a single positive integer. This is the number of lines that follow. Each of the following lines contains a single integer between 5 and 100, inclusive, which is the number of cells n.
Output
For each line, you must print out the number of prisoners that escape when the prison has n cells.
Sample Input
2
5
100
Sample Output
2
10
Source
Greater New York 2002

Solution:


Source Code:

//Tue Jun  1 14:05:04 EDT 2010
#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>

using namespace std;

int main(int argc, const char* argv[])
{
//  freopen("input.in", "r", stdin);
//  freopen("output.out", "w", stdout);
    int T;
    cin >> T;
    while (T--)
    {
        int N;
        cin >> N;
        vector<bool> v(N + 1, false);
        for (int i = 2; i <= N; i++)
        {
            for (int j = i; j <= N; j += i)
            {
                v[j] = v[j] ? false : true;
            }
        }
        int sum = 0;
        for (int i = 1; i <= N; i++)
        {
            if (v[i] == true)
                sum++;
        }
        cout << N - sum << endl;
    }
//  fclose(stdin);
//  fclose(stdout);
    return 0;
}

No comments :