Problem Links:
poj1182,Problem:
食物链
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 21064 | Accepted: 6073 |
动物王国中有三类动物A,B,C,这三类动物的食物链构成了有趣的环形。A吃B, B吃C,C吃A。
现有N个动物,以1-N编号。每个动物都是A,B,C中的一种,但是我们并不知道它到底是哪一种。
有人用两种说法对这N个动物所构成的食物链关系进行描述:
第一种说法是"1 X Y",表示X和Y是同类。
第二种说法是"2 X Y",表示X吃Y。
此人对N个动物,用上述两种说法,一句接一句地说出K句话,这K句话有的是真的,有的是假的。当一句话满足下列三条之一时,这句话就是假话,否则就是真话。
1) 当前的话与前面的某些真的话冲突,就是假话;
2) 当前的话中X或Y比N大,就是假话;
3) 当前的话表示X吃X,就是假话。
你的任务是根据给定的N(1 <= N <= 50,000)和K句话(0 <= K <= 100,000),输出假话的总数。
现有N个动物,以1-N编号。每个动物都是A,B,C中的一种,但是我们并不知道它到底是哪一种。
有人用两种说法对这N个动物所构成的食物链关系进行描述:
第一种说法是"1 X Y",表示X和Y是同类。
第二种说法是"2 X Y",表示X吃Y。
此人对N个动物,用上述两种说法,一句接一句地说出K句话,这K句话有的是真的,有的是假的。当一句话满足下列三条之一时,这句话就是假话,否则就是真话。
1) 当前的话与前面的某些真的话冲突,就是假话;
2) 当前的话中X或Y比N大,就是假话;
3) 当前的话表示X吃X,就是假话。
你的任务是根据给定的N(1 <= N <= 50,000)和K句话(0 <= K <= 100,000),输出假话的总数。
Input
第一行是两个整数N和K,以一个空格分隔。
以下K行每行是三个正整数 D,X,Y,两数之间用一个空格隔开,其中D表示说法的种类。
若D=1,则表示X和Y是同类。
若D=2,则表示X吃Y。
以下K行每行是三个正整数 D,X,Y,两数之间用一个空格隔开,其中D表示说法的种类。
若D=1,则表示X和Y是同类。
若D=2,则表示X吃Y。
Output
只有一个整数,表示假话的数目。
Sample Input
100 7 1 101 1 2 1 2 2 2 3 2 3 3 1 1 3 2 3 1 1 5 5
Sample Output
3
Source
Noi 01
Solution:
Disjoint set structure, find-union algorithms.
PS:
the key part of this problem is connect each other by using rank.
take care of what should the Find function return.
The report from N.
Source Code:
//Fri Jun 4 11:35:32 EDT 2010#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>
#define MMAX 50001
using namespace std;
/* Method One:
* (v[x].rank-v[y].rank+3)%3==0 表示x与y是同类
* (v[x].rank-v[y].rank+3)%3==1 表示x吃y
* (v[x].rank-v[y].rank+3)%3==2 表示y吃x
*
* Method Two:
* rank[x] 表示x与father[x]的关系:
* rank[x] == 0 表示x与 father[x] 是同类
* rank[x] == 1 表示x吃 father[x]
* rank[x] == 0 表示 father[x] 吃x
* */
class Predator
{
public:
int parent;
int rank;
};
vector<Predator> v(MMAX);
void Makeset(int N)
{
for (int i = 1; i <= N; i++)
{
v[i].parent = i;
v[i].rank = 0;
}
}
int Find(int x)
{
if (x == v[x].parent)
return x;
int temp = v[x].parent;
v[x].parent = Find(v[x].parent);
v[x].rank = (v[x].rank + v[temp].rank) % 3;
return v[x].parent;
}
void Union(int t1, int t2, int x, int y, int d)
{
v[t2].parent = t1;
v[t2].rank = (v[x].rank - v[y].rank + 6 - d) % 3;
}
int main(int argc, const char* argv[])
{
// freopen("input.in", "r", stdin);
// freopen("output.out", "w", stdout);
int N, M;
// cin >> N >> M;
scanf("%d%d", &N, &M);
Makeset(N);
int score = 0;
int a, b, c;
while (M--)
{
// cin >> a >> b >> c;
scanf("%d%d%d", &a, &b, &c);
if (b > N || c > N || (a == 2 && b == c))
{
score++;
continue;
}
int t1 = Find(b);
int t2 = Find(c);
if (t1 == t2)
{
if (a == 1 && v[b].rank != v[c].rank)
score++;
if (a == 2 && (v[b].rank - v[c].rank + 3) % 3 != a - 1)
score++;
}
else
{
Union(t1, t2, b, c, a - 1);
}
}
cout << score << endl;
// fclose(stdin);
// fclose(stdout);
return 0;
}
No comments :
Post a Comment