Problem Links:
poj1163,Problem:
The Triangle
| ||||||||
Description
7 3 8 8 1 0 2 7 4 4 4 5 2 6 5 (Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.
Input
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
Output
Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
Sample Output
30
Source
IOI 1994
Solution:
This is the most basic dynamic programming problem. I think this might be my first dp problem. haha.
Source Code:
//Mon Apr 12 10:33:15 CDT 2010#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>
using namespace std;
int LongestCommonSubstring(string A, string B)
{
int N = A.size();
int M = B.size();
vector<vector<int> > v(2, vector<int>(M+1, 0));
for(int i=0; i<=N; i++)
{
for(int j=0; j<=M; j++)
{
if(i==0 || j==0)
v[i%2][j] = 0;
else if(A[i-1] == B[j-1])
v[i%2][j] = v[(i-1)%2][j-1] + 1;
else
v[i%2][j] = max(v[(i-1)%2][j], v[i%2][j-1]);
}
}
return v[N%2][M];
}
int main( int argc, const char* argv[] )
{
freopen("input.in", "r", stdin);
freopen("output.out", "w", stdout);
int N;
while(cin >> N)
{
string str1;
cin >> str1;
string str2 = str1;
reverse(str2.begin(), str2.end());
cout << N - LongestCommonSubstring(str1, str2) << endl;
}
fclose(stdin);
fclose(stdout);
return 0;
}
No comments :
Post a Comment