Saturday, August 28, 2010

poj_1065_WoodenSticks.cpp

Problem Links:


poj1065,

Problem:


Wooden Sticks








Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 10865Accepted: 4415


Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output
The output should contain the minimum setup time in minutes, one per line.

Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1

Sample Output
2
1
3

Source
Taejon 2001

Solution:


Source Code:

#include<stdio.h>
#include<algorithm>
using namespace std;
struct tt
{
    int l,w;
}cx[5001];
bool cmp1(tt p, tt q)   //ÉýÐòÅÅÁÐ
{
    if(p.l!=q.l)
         return p.l<q.l;
    else
        return p.w<q.w;
}
int TempArray[5001];   //ÓÃÓÚ±£´æÈ¨ÖØ
/*********************************************
bool cmp2(tt p, tt q)
{
    return (p.w>q.w)||(p.w==q.w&&p.l>q.l);
}
*********************************************/
int GetTheMinTime(int n)
{
    int i,j;
    int logic;
    int MinT=0,index;
    for(i=1;i<=n;++i)
    {
        logic=-1;
        for(j=0;j<MinT;++j)
        {
            if(cx[i].w>=TempArray[j]&&logic<TempArray[j])
            {
                logic=TempArray[j];
                index=j;
            }
        }
        if(logic==-1)
            TempArray[MinT++]=cx[i].w;
        else
            TempArray[index]=cx[i].w;
    }
    return MinT;
}
int main(void)
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        int i;
        for(i=1;i<=n;i++)  
        {
            scanf("%d %d",&cx[i].l,&cx[i].w);
        }
        sort(cx,cx+n+1,cmp1);
        printf("%d\n",GetTheMinTime(n));
    }  
    return 0;
}

No comments :