Saturday, August 28, 2010

poj_1012_Joseph.cpp

Problem Links:

poj1012, uva00305,

Problem:

Joseph
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 30987 Accepted: 11603
Description
The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved. Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.
Input
The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.
Output
The output file will consist of separate lines containing m corresponding to k in the input file.
Sample Input
3
4
0
Sample Output
5
30
Source
Central Europe 1995

Solution:

Just print out the table.

Source Code:


#include <stdio.h>
int main()
{
    int k;
    while(scanf("%d",&k)&&k)
    {
        switch(k)
        {
        case 1:printf("2\n");break;
        case 2:printf("7\n");break;
        case 3:printf("5\n");break;
        case 4:printf("30\n");break;
        case 5:printf("169\n");break;
        case 6:printf("441\n");break;
        case 7:printf("1872\n");break;
        case 8:printf("7632\n");break;
        case 9:printf("1740\n");break;
        case 10:printf("93313\n");break;
        case 11:printf("459901\n");break;
        case 12:printf("1358657\n");break;
        case 13:printf("2504881\n");
        }
    }
    return 0;

}

No comments :